Faire un tableau Excel et trier les colonnes

Comment faire un tableau Excel et filtrer les données ? Créer d’abord les lignes et les colonnes requises. Remplir le tableau avec des données et le transformer en tableau avec des entêtes. Sous forme de tableau, il est possible de trier et filtrer les données facilement.

Comment faire un tableau Excel et le filtrer pour afficher et trier les lignes ?

Un tableau Excel est le type d’objet très utilisé par les professionnels. A ne pas confondre avec le logiciel Tableau.

Première étape : préparer la zone avec les colonnes

1 – Créer un nouveau fichier Excel, puis ajouter les colonnes. Dans cet exemple, c’est un budget prévisionnel mois pas mois, sur plusieurs années.

2 – Pour générer la suite de la liste des mois en toutes lettres, sélectionner les deux cellules Janvier et Février. Cliquer sur la petite croix et maintenir puis faire glisser la souris jusqu’à Décembre. Le résultat est donc une colonne année et douze colonnes pour les mois.

3 – Ajouter ensuite les années de 2020 à 2025, puis la colonne Total à droite, calculée avec une formule Excel simple. La formule Excel dans la cellule utilise la fonction SOMME :

=SOMME(C3:N3)
Ajouter le total annuel avec une formule

Pour faciliter la création de la formule, écrire la fonction SOMME puis sélectionner la première ligne des montants de Janvier à Décembre.

4 – Pour dupliquer les lignes, sélectionner la première ligne de Janvier à la colonne Total. Puis faire glisser vers le bas comme sur cette capture d’écran. Cette zone de cellules brutes, source du tableau, n’est pas filtrée ni mise en forme.

Dupliquer les lignes du tableau Excel et le total

Deuxième étape : mettre la zone de cellules sous forme de tableau

Cette partie montre comment mettre en forme le tableau Excel pour trier les données.

5 – Sélectionner toutes les cellules contiguës, pour cela, cliquer sur la cellule en haut à gauche. Puis utiliser le raccourci CTRL + A pour sélectionner toutes les données. Cette table ou zone Excel est en quelque sorte le tableau, sans mise en forme.

Sélectionner toutes les données d'un fichier Excel pour mettre en forme de tableau

6 – Sous Accueil, choisir ensuite l’option Mettre sous forme de tableau. Choisir la couleur et le style de tableau, ici c’est un tableau Orange.

Mettre sous forme de tableau Excel

7 – Ensuite, cocher l’option Mon tableau comporte des en-têtes, pour indiquer de prendre en compte les en-têtes préexistants. Cette action ne rajoutera donc pas de ligne au tableau.

Option Excel Mon tableau comporte des en-têtes

8 – Ajouter la ligne des totaux pour obtenir le total général avec toutes les années. Faire un clic-droit sur le tableau Excel, puis choisir Table et enfin sélectionner Ligne des totaux.

9 – Le résultat est un tableau Excel mis en forme. Il est possible de trier les cellules, par exemple par année ou encore de sélectionner uniquement l’année 2021 par exemple.

Tableau Excel mis en forme et sans quadrillage

Note: pour un affichage plus sobre, désactiver le quadrillage sur l’onglet Excel. Pour cela, dans le menu haut d’Excel, sous Affichage, décocher l’option Quadrillage.

Enfin, ce court article explique comment créer un tableau Excel pour trier et filtrer les données.