Extraer el día de la semana con Excel a partir de una fecha

¿Como extraer el día de la semana de una fecha, en letras con Excel ? Cuando se utilizan fechas en Excel, es más conveniente mostrar el nombre del día en lugar de la fecha en el formato de fecha de Excel. ¿Cómo mostrar el nombre del día de la semana de una fecha en su totalidad con Excel?

De hecho, cuando se utiliza Excel para gestionar los horarios, la legibilidad es importante. Aquí hay un artículo que muestra dos formas de saber el nombre del día de la semana en letras a partir de una fecha con una fórmula de Excel.

¿Cómo extraer el día de la semana con Excel?

El formato de fecha del tipo día/mes/año en numérico, como «30/11/2017» no es necesariamente el más fácil de leer. Especialmente con días menores o iguales a 12, porque el mes puede confundirse con el día. Y el formato anglosajón utiliza mes/día/año en su lugar, lo que puede dar fechas como 11/11/2011. Así que aquí es cómo convertir la fecha a día de Excel. Estos dos ejemplos concretos muestran el día escrito en letras.

1. Día de la semana completo a partir de la fecha del día

Para extraer el día en letras en Excel, una solución es utilizar la función de Excel TEXTO() con el parámetro del día de cuatro letras: dddd. Utilice la función con la fecha de hoy, por ejemplo, jueves:

=TEXTO(HOY(),"dddd")

2. Extraer el nombre del día completo desde otra celda

Utilice la función con la fecha contenida en otra celda del libro de Excel, como en el ejemplo siguiente:

=TEXTO(B2,"dddd")

3. Extraer el día de la semana en mayúsculas a partir de una fecha

Para convertir la fecha de hoy en letras con Excel en mayúsculas esta vez. Utilice siempre la fórmula TEXTO, pero esta vez con el parámetro en mayúsculas: DDDD, como en este ejemplo, que mostrará JUEVES.

=TEXTO(B2; "DDDD")

Así, esta fórmula mostrará el nombre del día con todas las letras. Es decir, el día completo. En este ejemplo la columna tendrá el siguiente formato: Jueves

Utilisar la función TEXTO para extraer el día de la semana con Excel
Utilisar la función TEXTO para extraer el día de la semana con Excel

Las capturas de pantalla son de una versión inglesa de Excel. El equivalente de la función española TEXTO() es TEXT() en inglés.

4. Formula para extraer el día sólo en tres letras

En otras palabras, es possible mostrar sólo las tres primeras letras del día en une formula Excel. Para ello, utilice la función TEXTO() con la palabra clave ddd.

=TEXTO(B2,"ddd")

En este ejemplo para convertir una fecha de Excel en un día, la celda mostrará: Jue (por Jueves)

Función Excel TEXT para extraer el día de la semana en tres letras
Función Excel TEXT para extraer el día de la semana en tres letras

Además, la lista de días de la semana con la fórmula que utiliza la palabra clave de tres letras mostrará los días abreviados:

  • Lun
  • Mar
  • Mié
  • Jue
  • Vie
  • Sáb
  • Dom

Para terminar con la función de texto de Excel

Para concluir, este artículo presenta cómo extraer los días de la semana de forma más explícita. Tenga en cuenta que esta fórmula también le permite gestionar el formato de las diferentes informaciones. Entre otros: horas, semanas, meses y años, pero también porcentajes, monedas con el símbolo del euro (€) o del dólar ($), por ejemplo.

Para ir más allá, aquí hay un artículo sobre cómo desactivar el bloqueo de desplazamiento en Excel.

Desactivar el bloqueo de desplazamiento en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *